29 lines
686 B
Nix
29 lines
686 B
Nix
{ config, ... }:
|
|
{
|
|
imports = [ ./caddy.nix ];
|
|
services = {
|
|
webdav = {
|
|
enable = true;
|
|
settings = {
|
|
address = "0.0.0.0";
|
|
port = 6065;
|
|
debug = true;
|
|
behindProxy = true;
|
|
directory = "/srv/webdav";
|
|
users = [
|
|
{
|
|
username = "pixelifytica";
|
|
password = "{bcrypt}$2b$12$ulThbG9JGJP/FYI4RyX8sufMOE/vfw928gJMFedajiINbqx585wY.";
|
|
permissions = "CRUD";
|
|
}
|
|
];
|
|
};
|
|
};
|
|
caddy.virtualHosts."files.xenia.me.uk".extraConfig =
|
|
let
|
|
inherit (config.services.webdav.settings) port;
|
|
in
|
|
"reverse_proxy http://localhost:${toString port}";
|
|
};
|
|
}
|