32 lines
618 B
Nix
32 lines
618 B
Nix
{ config, ... }:
|
|
{
|
|
programs.bottom = {
|
|
enable = true;
|
|
settings = {
|
|
flags = {
|
|
group_processes = true;
|
|
temperature_type = "celsius";
|
|
battery = true;
|
|
enable_gpu = true;
|
|
enable_cache_memory = true;
|
|
};
|
|
colors =
|
|
let
|
|
scheme = config.lib.stylix.scheme.withHashtag;
|
|
rainbow = with scheme; [
|
|
red
|
|
yellow
|
|
green
|
|
cyan
|
|
blue
|
|
magenta
|
|
];
|
|
in
|
|
{
|
|
cpu_core_colors = rainbow;
|
|
gpu_core_colors = rainbow;
|
|
};
|
|
};
|
|
};
|
|
}
|