Evie Litherland-Smith
a344322f3d
Python and lua live under programming, with programming/default.nix importing both and including misc tools that don't fit anywhere else Texlive move to own directory
24 lines
374 B
Nix
24 lines
374 B
Nix
{ pkgs, ... }:
|
|
{
|
|
imports = [
|
|
./python/default.nix
|
|
./lua/default.nix
|
|
];
|
|
home.packages = with pkgs; [
|
|
## Linters
|
|
shellcheck
|
|
yamllint
|
|
|
|
## Formatters
|
|
nixfmt-rfc-style
|
|
shfmt
|
|
nodePackages.prettier
|
|
nodePackages.prettier-plugin-toml
|
|
|
|
## Language servers
|
|
nixd
|
|
rust-analyzer
|
|
nodePackages.typescript-language-server
|
|
];
|
|
}
|