nixos/system/Ronin.nix
Evie Litherland-Smith 52130c59cc Add home monitors to Ronin config
Add monitor mode and scale to sway config, add extra profile for
kanshi for home configuration.
2024-09-18 11:34:19 +01:00

106 lines
2.7 KiB
Nix

{ pkgs, username, ... }:
{
imports = [ ./laptop.nix ];
home-manager.users.${username} = {
imports = [ ./home/work.nix ];
wayland.windowManager.sway.config = {
output = {
# Work
"Dell Inc. DELL P3223QE CCG8YN3".scale = "1.5";
# Home
"Acer Technologies ED270R TJMEE0043W01".mode = "1920x1080@120Hz";
"Microstep MSI G27CQ4 E2 Unknown" = {
mode = "2560x1440@120Hz";
scale = "1.25";
};
};
workspaceOutputAssign = [
{
output = "eDP-1";
workspace = "1";
}
];
};
services.kanshi = {
enable = true;
settings =
let
laptopScreen.criteria = "eDP-1";
workMonitor.criteria = "Dell Inc. DELL P3223QE CCG8YN3";
homeMonitor1.criteria = "Acer Technologies ED270R TJMEE0043W01";
homeMonitor2.criteria = "Microstep MSI G27CQ4 E2 Unknown";
in
[
{
profile = {
name = "default";
outputs = [
{
inherit (laptopScreen) criteria;
status = "enable";
position = "0,0";
}
];
};
}
{
profile = {
name = "work";
outputs = [
{
inherit (laptopScreen) criteria;
status = "disable";
}
{
inherit (workMonitor) criteria;
status = "enable";
position = "0,0";
}
];
};
}
{
profile = {
name = "home";
outputs = [
{
inherit (laptopScreen) criteria;
status = "disable";
}
{
inherit (homeMonitor1) criteria;
status = "enable";
position = "0,140";
}
{
inherit (homeMonitor2) criteria;
status = "enable";
position = "1920,0";
}
];
};
}
];
};
};
boot.initrd = {
secrets = {
"/crypto_keyfile.bin" = null;
};
luks.devices."luks-761eeb11-3091-4142-9232-4fb33165eccd" = {
device = "/dev/disk/by-uuid/761eeb11-3091-4142-9232-4fb33165eccd";
keyFile = "/crypto_keyfile.bin";
};
};
environment = {
etc."ppp/options".text = ''
ipcp-accept-remote
'';
systemPackages = with pkgs; [ openfortivpn ];
};
services = {
samba.enable = true;
hardware.bolt.enable = true;
};
}