93 lines
2.5 KiB
Nix
93 lines
2.5 KiB
Nix
{
|
|
description = "Evie's machine configurations";
|
|
|
|
nixConfig = {
|
|
extra-substituters = [
|
|
"https://nix.xenia.me.uk"
|
|
"https://cosmic.cachix.org/"
|
|
];
|
|
extra-trusted-public-keys = [
|
|
"nix.xenia.me.uk:tlgwOaG5KMLjQUk2YaErS8mAG69ZCr3PaHXZYi+Y5eI="
|
|
"cosmic.cachix.org-1:Dya9IyXD4xdBehWjrkPv6rtxpmMdRel02smYzA85dPE="
|
|
];
|
|
};
|
|
|
|
inputs = {
|
|
nixpkgs.follows = "nixos-cosmic/nixpkgs-stable";
|
|
nixos-cosmic.url = "github:lilyinstarlight/nixos-cosmic";
|
|
home-manager = {
|
|
url = "github:nix-community/home-manager/release-24.05";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
plasma-manager = {
|
|
url = "github:nix-community/plasma-manager";
|
|
inputs = {
|
|
nixpkgs.follows = "nixpkgs";
|
|
home-manager.follows = "home-manager";
|
|
};
|
|
};
|
|
stylix = {
|
|
url = "github:danth/stylix";
|
|
inputs = {
|
|
nixpkgs.follows = "nixpkgs";
|
|
home-manager.follows = "home-manager";
|
|
};
|
|
};
|
|
nix-index-database = {
|
|
url = "github:nix-community/nix-index-database";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
iosevka-custom.url = "git+https://git.xenia.me.uk/pixelifytica/iosevka.git";
|
|
};
|
|
|
|
outputs =
|
|
inputs@{ nixpkgs, ... }:
|
|
{
|
|
nixosConfigurations = {
|
|
## Server
|
|
Legion = nixpkgs.lib.nixosSystem {
|
|
specialArgs = {
|
|
inherit inputs;
|
|
username = "pixelifytica";
|
|
hostName = "Legion";
|
|
};
|
|
modules = [ ./system/default.nix ];
|
|
};
|
|
## Personal
|
|
Vanguard = nixpkgs.lib.nixosSystem {
|
|
specialArgs = {
|
|
inherit inputs;
|
|
username = "pixelifytica";
|
|
hostName = "Vanguard";
|
|
};
|
|
modules = [ ./system/default.nix ];
|
|
};
|
|
Northstar = nixpkgs.lib.nixosSystem {
|
|
specialArgs = {
|
|
inherit inputs;
|
|
username = "pixelifytica";
|
|
hostName = "Northstar";
|
|
};
|
|
modules = [ ./system/default.nix ];
|
|
};
|
|
## Work
|
|
Tone = nixpkgs.lib.nixosSystem {
|
|
specialArgs = {
|
|
inherit inputs;
|
|
username = "elitherl";
|
|
hostName = "Tone";
|
|
};
|
|
modules = [ ./system/default.nix ];
|
|
};
|
|
Ronin = nixpkgs.lib.nixosSystem {
|
|
specialArgs = {
|
|
inherit inputs;
|
|
username = "elitherl";
|
|
hostName = "Ronin";
|
|
};
|
|
modules = [ ./system/default.nix ];
|
|
};
|
|
};
|
|
};
|
|
}
|