Add zathura with some initial config, colour scheme is currently incomplete but placeholder comments in place for required keys. Don't autostart twinkle on work machines, some issue with detected ALSA source/sink.
91 lines
2.2 KiB
Nix
91 lines
2.2 KiB
Nix
{ config, pkgs, ... }:
|
|
{
|
|
imports = [
|
|
./sway/default.nix
|
|
./alacritty/default.nix
|
|
./emacs/default.nix
|
|
./browser/default.nix
|
|
./zathura/default.nix
|
|
./services/email/default.nix
|
|
];
|
|
home = {
|
|
packages = with pkgs; [
|
|
libreoffice-fresh
|
|
webcord
|
|
signal-desktop
|
|
teams-for-linux
|
|
];
|
|
pointerCursor =
|
|
let
|
|
name = if config.scheme.variant == "light" then "volantes_cursors" else "volantes_light_cursors";
|
|
in
|
|
{
|
|
inherit name;
|
|
package = pkgs.volantes-cursors;
|
|
size = 32;
|
|
gtk.enable = config.gtk.enable;
|
|
x11 = {
|
|
enable = true;
|
|
defaultCursor = name;
|
|
};
|
|
};
|
|
};
|
|
services.syncthing.enable = true;
|
|
programs.mpv.enable = true;
|
|
xdg = {
|
|
mime.enable = true;
|
|
mimeApps =
|
|
let
|
|
defaultApplications = import ./mimeapps/default.nix;
|
|
in
|
|
{
|
|
enable = true;
|
|
inherit defaultApplications;
|
|
associations = {
|
|
added = defaultApplications;
|
|
removed = {
|
|
"x-scheme-handler/zoomus" = config.xdg.mimeApps.defaultApplications."x-scheme-handler/http";
|
|
};
|
|
};
|
|
};
|
|
userDirs = {
|
|
enable = true;
|
|
createDirectories = true;
|
|
extraConfig = {
|
|
XDG_PROJECTS_DIR = "${config.home.homeDirectory}/Projects";
|
|
};
|
|
};
|
|
configFile = {
|
|
"autostart/signal-desktop.desktop".source = "${pkgs.signal-desktop}/share/applications/signal-desktop.desktop";
|
|
"teams-for-linux/config.json".text = builtins.toJSON {
|
|
awayOnSystemIdle = true;
|
|
closeAppOnCross = true;
|
|
followSystemTheme = true;
|
|
notificationMethod = "electron";
|
|
optInTeamsV2 = true;
|
|
spellCheckerLanguages = [ "en_GB" ];
|
|
};
|
|
};
|
|
};
|
|
xresources.properties = with config.scheme.withHashtag; {
|
|
"*background" = base00;
|
|
"*foreground" = base05;
|
|
"*color0" = base00;
|
|
"*color1" = red;
|
|
"*color2" = green;
|
|
"*color3" = yellow;
|
|
"*color4" = blue;
|
|
"*color5" = magenta;
|
|
"*color6" = cyan;
|
|
"*color7" = base04;
|
|
"*color8" = base01;
|
|
"*color9" = red;
|
|
"*color10" = green;
|
|
"*color11" = yellow;
|
|
"*color12" = blue;
|
|
"*color13" = magenta;
|
|
"*color14" = cyan;
|
|
"*color15" = base05;
|
|
};
|
|
}
|