nix-background-upgrade/shell.nix
Evie Litherland-Smith e170c2c50e Abstract switch calling mechanic, add proper returncode checking
Catch different failure modes of subprocess.run

Add default versions of NIXOS_CONFIGURATION and
HOME_MANAGER_CONFIGURATION to compare to env vars, assume
configuration is a flake if different and append "--flake" argument to
process commands
2024-06-06 06:12:57 +01:00

16 lines
402 B
Nix

{
pkgs ? import <nixpkgs> {},
mkPoetryEnv ? ((builtins.getFlake "github:nix-community/poetry2nix").lib.mkPoetry2Nix {inherit pkgs;}).mkPoetryEnv,
}:
pkgs.mkShellNoCC {
packages = with pkgs; [
(mkPoetryEnv {
projectDir = ./.;
preferWheels = true;
editablePackageSources = {nix_background_upgrade = ./src;};
extraPackages = ps: with ps; [mypy];
})
poetry
];
}