iosevka/default.nix

38 lines
990 B
Nix

{
stdenv,
iosevka,
nerd-font-patcher,
}: let
customBuildPlan = import ./custom-build-plan.nix;
in {
iosevka-custom-aile = iosevka.override {
set = "aile";
privateBuildPlan = {
inherit (customBuildPlan) noCvSs exportGlyphNames variants weights;
family = "Iosevka Custom Aile";
spacing = "quasi-proportional";
serifs = "sans";
};
};
iosevka-custom-nerdfont = let
monospace = iosevka.override {
set = "custom";
privateBuildPlan = {
inherit (customBuildPlan) noCvSs exportGlyphNames variants weights;
family = "Iosevka Custom";
spacing = "normal";
serifs = "sans";
};
};
in
stdenv.mkDerivation {
name = "${monospace.name}-nerd-font-patched";
src = monospace;
nativeBuildInputs = [nerd-font-patcher];
buildPhase = ''
find \( -name \*.ttf -o -name \*.otf \) -execdir nerd-font-patcher -c {} \;
'';
installPhase = "cp -a . $out";
};
}