This repository has been archived on 2024-07-03. You can view files and clone it, but cannot push or open issues or pull requests.
home-manager/work.nix
Evie Litherland-Smith c6a8a7c34e Fix correct username not being set
Rather than set username in flake.nix, set a default value in
default.nix (since it's always called), and set appropriate values in
personal.nix (pixelifytica) and work.nix (elitherl), since the two
files are mutually exclusive and only one or the other will be
imported.
2024-06-24 09:15:17 +01:00

33 lines
805 B
Nix

{
config,
lib,
pkgs,
...
}: {
home = {
username = "elitherl";
packages = with pkgs; [
twinkle
teams-for-linux
(writeShellScriptBin "ukaea-vpn-connect"
"sudo ${openfortivpn}/bin/openfortivpn -c ${./ukaea-vpn.conf}")
];
};
programs = {
git.userEmail = config.accounts.email.accounts.outlook.address;
firefox.policies.Homepage.URL = "https://nucleus.ukaea.uk";
};
accounts.email.accounts = {
proton.primary = lib.mkForce false;
outlook.primary = lib.mkForce true;
};
xdg.configFile."teams-for-linux/config.json".text = builtins.toJSON {
awayOnSystemIdle = true;
closeAppOnCross = true;
followSystemTheme = true;
notificationMethod = "electron";
optInTeamsV2 = true;
spellCheckerLanguages = ["en_GB"];
};
}