This repository has been archived on 2024-07-03. You can view files and clone it, but cannot push or open issues or pull requests.
home-manager/home/Tone.nix
Evie Litherland-Smith bae8a7b912 Add sway/window to alt waybar config
Slightly change monitor config definition
2024-06-16 06:34:50 +01:00

41 lines
772 B
Nix

{...}: {
imports = [./work.nix];
wayland.windowManager.sway.config = {
output."eDP-1".scale = "1.25";
workspaceOutputAssign = [
{
output = "eDP-1";
workspace = "1";
}
];
};
services.kanshi = {
enable = true;
settings = let
laptopScreen = {
criteria = "eDP-1";
scale = 1.25;
position = "2560,576";
};
monitor = {
criteria = "Dell Inc. DELL P3223QE CCG8YN3";
scale = 1.5;
position = "0,0";
};
in [
{
profile = {
name = "undocked";
outputs = [laptopScreen];
};
}
{
profile = {
name = "docked";
outputs = [laptopScreen monitor];
};
}
];
};
}