46 lines
958 B
Nix
46 lines
958 B
Nix
{...}: {
|
|
imports = [./default.nix];
|
|
wayland.windowManager.sway.config = {
|
|
output."eDP-1".scale = "1.25";
|
|
workspaceOutputAssign = [
|
|
{
|
|
output = "eDP-1";
|
|
workspace = "1";
|
|
}
|
|
];
|
|
};
|
|
services.kanshi = {
|
|
enable = true;
|
|
settings = let
|
|
laptopScreen = {
|
|
criteria = "eDP-1";
|
|
scale = 1.25;
|
|
position = "3000,636";
|
|
};
|
|
monitor1 = {
|
|
criteria = "Acer Technologies ED270R TJMEE0043W01";
|
|
mode = "1920x1080@165Hz";
|
|
position = "1080,420";
|
|
};
|
|
monitor2 = {
|
|
criteria = "Ancor Communications Inc VS278 FALMQS032358";
|
|
position = "0,0";
|
|
transform = "270";
|
|
};
|
|
in [
|
|
{
|
|
profile = {
|
|
name = "undocked";
|
|
outputs = [laptopScreen];
|
|
};
|
|
}
|
|
{
|
|
profile = {
|
|
name = "docked";
|
|
outputs = [laptopScreen monitor1 monitor2];
|
|
};
|
|
}
|
|
];
|
|
};
|
|
}
|